Export nach GIS-Nebenbestimmungen in NET Engineering

Der Export nach GIS-Nebenbestimmungen (früher BMVI-Export) dient zum Erzeugen der Shape- oder GeoJSON-Dateien, welche für einen Fördermittelantrag/Verwendungsnachweis nach den entsprechenden Richtlinien nötig ist. 

Die GIS-Nb unterscheiden die Projekte in vier Verfahrensschritte. Diese werden in NET Design und NET Engineering "Phasen" genannt. Eine Erläuterung der Phasen und ob diese nur in NET Engineering oder auch in NET Design exportiert werden können finden Sie hier

Ist das Projekt wie hier erläutert vorbereitet, können im Projekt alle zusätzlich benötigten Informationen hinterlegt werden. In diesem Beitrag wird darauf eingegangen, in welchen Formularen zusätzliche Informationen zu hinterlegen sind und welche Layer zusätzlich angelegt werden müssen. Des Weiteren wird erklärt, wie der Export gestartet wird und welche Optionen möglich sind.

Eine Übersicht welche Attribute in welchen GIS-Nb automatisch befüllt werden, bzw. aus welchem Layer diese in den Export geschrieben werden, erhalten Sie hier.

GIS-Nb spezifische Layer

Es gibt eine Reihe von Layern, welche nur für den Export nach GIS-Nb benötigt werden. Es handelt sich hierbei um Polygonlayer. Bitte beachten Sie, dass davon je nach verwendeter Version der GIS-Nb nicht alle Layer benötigt werden. Eine Ausnahme hiervon ist der Layer "GIS-NB Antragsteller". Dieser ist zwingend erforderlich, da der Export nach GIS-Nb über das Formular des "GIS-NB Antragstellers" gestartet wird.

Die meisten GIS-Nb spezifischen Layer können über die Arbeitsabläufe erstellt werden:

  • Arbeitsabläufe_net_gisnb.pngAntragsteller (Gebietsgrenze)
  • Ausbaugebiet BFP
  • Ausbaugebiet (fremd)
  • Markterkundungsgebiet
  • Weiße Flecken

Bei der Erstellung über einen Arbeitsablauf können Sie auch benötigte Felder bereits befüllen. Bitte beachten Sie, dass nicht immer alle Attribute in jeder Version der GIS-Nb befüllt sein müssen. Konsultieren Sie hierzu bitte die GIS-Nb um dies zu erfahren. Eine Orientierung kann auch die genaue Aufschlüsselung der Attributszuordnung geben.

Versorgungsgebiet

Wenn das NET Engineering Projekt durch eine überführte NET Design Grobplanung mit aktiviertem GIS-Nb Modul entstanden ist, dann sind die Versorgungsgebiete bereits vorhanden und entsprechen den Clustern der Hauptkabelebene.

Da bei den Versorgungsgebieten das versorgende Netzelement ausgewählt werden muss. Ist dies leider während eines Arbeitsablaufes nicht möglich.

Wünschen Sie weitere Versorgungsgebiete oder wurde das Projekt nicht aus NET Design überführt, müssen Sie die Versorgungsgebiete von Hand anlegen. Hierzu gehen Sie wie folgt vor:

  1. Öffnen Sie das Formular Versorgungsgebiet.
    open_form_versorgungsgebiet.png
  2. Klicken Sie auf die "Sonne" im unteren Formularbereich.
    new_object.png
  3. Füllen Sie die beiden rot hinterlegten Felder.
    new_versorgungsgebiet.png
    In dem Auswahl Menu POP können Sie nur eine FID auswählen. Da diese nicht sprechend ist, nutzen Sie am Besten den "F"-Button. Mit diesem können Sie ein Objekt von der Karte wählen und dieses wird hier eingesetzt. Dabei muss es sich um eine LWL Muffe oder einen LWL Abschluss handeln. Die "Leuchte" hebt das gewählte Objekt hervor. Dieser ist also bei der Erstellung des Objektes noch ohne Funktion.
    Klicken Sie im Anschluss auf "Einfügen" oder nutzen Sie die Taste "F5".
  4. Nutzen Sie nun im unteren Bereich des Fensters entweder das Icon für "Neue Geometrie für ausgewähltes Objekt digitalisieren" 
    create_geometry.png
    oder alternativ das Icon für "Vorhandene Geometrie mit ausgewähltem Objekt verbinden". Mit diesem können Sie eine bereits vorhandene Geometrie (also ein bestehendes Cluster) dem Objekt zuordnen.
    link_geometry.pngBeachten Sie: Sollten Sie ein bestehendes Cluster verknüpfen, kann es ratsam sein, diese Geometrie und das Cluster zu erhalten.

Fördervorhaben

Die Objektklasse Fördervorhaben ist dann wichtig, wenn innerhalb des Antragstellers oder Projektes verschiedene Fördermittelanträge gestellt werden sollen. Dies kann geschehen, weil bestimmte Objekte innerhalb des Gebietes eine andere Förderung erhalten. Eine weitere Variante wäre, dass der ursprüngliche Ausbau noch im Gange ist und bereits die Nachverdichtung gefördert wird.

Das Fördervorhaben muss an jedem Objekt angetragen werden, wenn diese benutzt werden sollen. Danach kann beim Export bestimmt werden, mit welchem GIS-Nb Zustand diese exportiert werden sollen oder weggelassen werden sollen.

GIS-Nb spezifische Attribute

Es gibt eine Reihe von zusätzlichen Attributen, die für einen erfolgreichen Export befüllt werden müssen. Hier erhalten Sie eine Übersicht darüber, welche dies sind und wo Sie diese finden. Auch für diese Attribute gilt, dass je nach Version der GIS-Nb eventuell nicht alle zu befüllen sind.

Das es in einem Layer GIS-Nb spezifische Attribute gibt, erkennen Sie im Formular. Bei den entsprechenden Layern gibt es einen Reiter "GIS-NB."

formular-tabs.png

Layer, welche es nur für den Export nach GIS-Nb gibt, werden hier nicht gesondert aufgelistet. Die Attribute im GIS-Nb Tab sind stets von Hand zu befüllen. Dabei sollten Sie darauf achten, dass Sie nicht immer alle Attribute befüllen müssen. Dies ist abhängig von der Version der GIS-Nb, welche Sie verwenden und der Phase, die Sie exportieren möchten.

Die Auflistung hier erfolgt anhand der Reihenfolge, in der Sie die Layer im Fachschalenexplorer finden.

Mast/Schacht/Schrank

eng_manhole.png

In den Formularen für "Mast", "Schacht" und "Schrank" sind die Attribute unter dem GIS-Nb Reiter identisch. Die Attribute, die GIS-Nb spezifisch sind, beginnen bei den Fördervorhaben. Da eindeutige Bezeichner benötigt werden, sollten die Namen ebenfalls befüllt werden und möglichst eindeutig sein. Sie werden für die Layer "Bauten", beziehungsweise "Bauten und Netztechnik" verwendet. Abgesehen von der Export ID, sind diese von Hand zu befüllen. Das Formular verweist mit den Attributen im Kopf auf die Tabelle TC_POINT. Das Formular Mast verweist mit den anderen Attributen auf die Tabelle TC_SP_POLE. Das Schacht Formular nutzt die Tabelle TC_SP_MANHOLE. Das Formular für die Schränke verweist auf die Tabelle TC_SP_CABINET.

Trasse

eng_segment.png

Auch im Formular Trasse finden Sie unter dem Tab GIS-NB, die für den Export nach GIS-Nb spezifischen zusätzlichen Attribute. Hier sind diese unter der Trennlinie zu finden. Mit Ausnahme der Export Id, müssen diese Attribute manuell befüllt werden. Der Name der Trasse stammt aus der Tabelle TC_LINE, genauso wie die Trassengeometrie. Die weiteren Attribute stammen aus der Tabelle TC_SP_SEGMENT.

LWL Abschluss

eng_lwl_terminator.png

Die Angaben aus dem LWL-Abschlussformular werden unter anderem für den Layer "Netztechnik" und den Layer "Bauten und Netztechnik" benötigt.  Auch hier sind die notwendigen Attribute im Reiter "GIS-NB" unter der Trennlinie zu finden. Diese verweisen auf die Tabelle TC_FO_TERMINATOR. Die Geometrie und der Name finden sich in der Tabelle TC_POINT.

LWL Kabelabschnitt

eng_lwl_cable.png

Die Informationen für den Layer "Verbindungen" stammen aus dem LWL-Kabelabschnitt. Die Geometrie wird für gewöhnlich dem Trassenverlauf und der TC_LINE entnommen. Die Attribute sind von Hand zu befüllen. Das Formular nutzt die Tabelle "TC_FO_CABLE".

LWL Muffe

eng_lwl_closure.png

Auch im Muffenformular gibt es einen GIS-NB Reiter. Die zusätzlich für den Export benötigten Attribute befinden sich unter dem Trennstrich. Die Informationen, welche hier abgefragt werden dienen zum Befüllen der Layer "Netztechnik" beziehungsweise "Bauten und Netztechnik". Die Geometrie und der Name stammen aus der TC_POINT Tabelle, während die muffenspezifischen Attribute aus der Tabelle TC_FO_CLOSURE stammen.

Rohr

eng_duct.png

Der Layer "Leerrohr" und der Layer "Mitverlegung" werden zu einem großen Teil aus den Informationen in der Objektklasse Rohr (TC_SP_DUCT) gefüllt. Wie auch bei den meisten anderen Layern, stammen nur die für das Rohr spezifischen Informationen aus dieser Objektklasse, während die Geometrieinformationen aus der Objektklasse TC_LINE stammen. Dabei gibt es hier mehrere Besonderheiten. Der Layer "Mitverlegung" wird nur befüllt, wenn es Rohre gibt, bei denen das Attribut "Mitverlegt" auf "Ja" gesetzt wurde. Die zweite Besonderheit ist, dass die Zuordnung der Rohrtypen automatisch über den verwendeten "Typ" erfolgt. Dabei werden die entsprechenden Parameter im Rohrtyp festgelegt. Die Erläuterung, wie dies erfolgt, wird im entsprechenden Formular erläutert.

Rohr im Schutzrohr

Wenn Rohrverbände oder Einzelrohre in bestehende Schutzrohre eingezogen werden, müssen diese am Beginn und am Ende der Einführung in das Schutzrohr getrennt sein. Die Ursache hierfür liegt in der korrekten Bestimmung der Verlegetiefe. Sind Rohre nicht so getrennt, kann der Export nicht durchgeführt werden.

Rohrtyp

eng_duct_type.png

Der Rohrtyp für den Export nach GIS-Nb wird über den GIS-NB Reiter im Rohrtypformular (Stammdaten Rohr) festgelegt. Im obigen Screenshot ist markiert, welche Attribute dabei wichtig sind.

Wenn im unteren markierten Teil ein Rohrtyp festgelegt wurde, wird dieser verwendet. Wurde das nicht getan, wird versucht über den Namen den Rohrtyp zu bestimmen. Wird im Namen zum Beispiel 10/6 verwendet, wird automatisch der Rohrtyp 10/6 zugeordnet. Es wird dann davon abhängig gemacht, ob es ein Einzelrohr oder ein Verband ist, ob eine Rohrkonfiguration vorhanden ist oder nicht. Gelingt dies nicht und ist kein Rohrtyp angelegt, wird das Rohr entweder als Kabelschutzrohr zugeordnet oder als sonstiger Rohrtyp exportiert. Dabei wird dann der Name als Ergänzung verwendet.

Es wird die Tabelle TC_SP_DUCT_TYPE verwendet.

Gebäude

eng_building.png

Die GIS-Nb spezifischen Attribute befinden sich im Gebäudeformular im GIS-Nb Tab- unterhalb der Überschrift "GIS-NB". Die meisten der Attribute im Gebäudeformular werden in den Layer "Projektgebiet" exportiert. Dieses verweist auf die Tabelle TC_TG_BUILDING.

Im Layer Gebäude gibt es eine Besonderheit, dies ist die UUID. Diese können Sie über den UUID Import importieren.

UUID Import

Die UUID wird Ihnen vom Projektträger mitgeteilt oder Sie können diese beim Projektantrag herunterladen. Beim Import wird anhand eventuell vorhandener UUIDs, sowie den in der Import-Datei vorhandenen Adressdaten verglichen. Das bedeutet, die Adressen sollten entweder über einen Import erzeugt werden oder Sie sollten Straßen- und Ortsnamen sowie Hausnummern genauso schreiben, wie der Projektträger. Bitte beachten Sie, dass der UUID Import nur die UUID in vorhandene Features importiert.

Der UUID Import wird, genauso wie die Exporte nach GIS-Nb, über das Formular "Antragsteller (Gebietsgrenze)" gestartet. Dort finden Sie den UUID Import im Menu Bearbeiten.

Bitte beachten Sie, dass ein Gebäude im Layer "Endverbraucher" nur beachtet wird, wenn diesem ein LWL-Abschluss zugeordnet ist.

Start des GIS-Nb Exports

Wie bereits unter GIS-Nb spezifische Layer erwähnt, wird der Export nach GIS-Nb über das Formular "Antragsteller (Gebietsgrenze)" gestartet.

eng_political_area_with_menu.png

  1. Öffnen Sie das Formular.
  2. Suchen Sie das Gebiet, welches Sie exportieren möchten, falls mehrere im Projekt enthalten sind.
  3. Klicken Sie auf das Menü "Bearbeiten".
  4. Im Menu klicken Sie auf "GIS-NB Export".

Einstellungen im Export Dialog

Nachdem Sie auf "GIS-NB Export" geklickt haben, erscheint das folgende Fenster.

eng_export_wizard.png

Bitte warten Sie bis die Fördervorhaben geladen sind. Dies kann einen kurzen Moment dauern. Im oberen Bereich können Sie über das Auswahlmenu festlegen, welche Version der GIS-Nb und welche Phase Sie exportieren möchten.

Im Bereich "Fördervorhaben" können Sie festlegen, welchen GIS-Nb Zustand die Objekte eines Fördervorhabens im Export haben sollen. Hier kann gewählt werden, ob der Zustand, welche am Objekt eingestellt ist verwendet werden soll, ob die Objekte als "Neubau" oder "Bestand" (vor Ausbau vorhanden) oder gar nicht exportiert werden sollen.

Schließlich können Sie noch entscheiden, ob nur Objekte, welche einen bestimmten Status haben, exportiert werden sollen. Dabei gilt zu beachten, dass es zu Fehlern kommen kann, wenn dadurch kein zusammenhängendes Netz entsteht. Es stehen die Status zur Auswahl, welche in der Tabelle TC_STATUS eingetragen wurden.

eng_export_wizard_p1_options.png

Nachdem Sie die Einstellungen wie gewünscht getroffen haben, klicken Sie auf "Weiter". Dann erreichen Sie den zweiten Schritt des Exportassistenten- "Erweiterte Einstellungen".

eng_export_wizard_p2_options.png

Sie können über das erste Auswahlmenü bestimmen, wie die Kabellänge ermittelt wird. Entweder verwenden Sie die über die Linie ermittelte Länge, die "CAD-Länge" oder Sie können auch die im Formular eingetragene Nutzerlänge zu Grunde legen oder aber Sie verwenden die ermittelte "CAD-Länge" plus die eingetragene Länge der Kabelreserven.

Das zweite Auswahlmenü dient der Auswahl der "Richtung der Netzverfolgung". Bitte belassen Sie dies in der Regel bei der "Automatischen Erkennung". Die Option könnte dann interessant werden, wenn sehr wenige Anschlusspunkte exportiert werden sollen.

Sie können entscheiden, ob die Dämpfung berechnet werden soll oder die Dämpfungswerte aus dem GIS-NB Reiter des Gebäudeformulars verwendet werden sollen. Bitte beachten Sie, dass bei der Berechnung alle LWL Komponenten auch einen Wert für die Dämpfung eingetragen haben sollten.

Wenn Sie den Haken bei "Übereinanderliegende Linien zusammenfassen" setzen, werden Rohre und Kabel mit gleicher Geometrie und gleichen Attributen zu einer Linie zusammengefasst. Diese Einstellung ist mit einem Export des zusätzlichen Attributes "Bezeichner" inkompatibel.

Der Haken bei "Bauten ohne Netztechnik exportieren" führt dazu, dass alle Strukturen (Masten, Schächte, Schränke, Ziehschächte, etc.) exportiert werden. Unabhängig davon ob diese einen LWL-Abschluss oder eine LWL-Muffe enthalten. Wenn der Haken entfernt wird, werden nur die Strukturen exportiert, mit denen Netztechnik verknüpft ist.

Die Option "Netztechnik und zugehörige Bauten exportieren" gibt es bei allen Exporten nach GIS-Nb 4.0 oder höher. Wenn man diese Option aktiviert, dann werden zusätzlich zur Netztechnik, auch die Strukturen als einzelner Punkt exportiert. Laut GIS-Nb 4.0 scheint dies nicht erforderlich zu sein, dies ist aber Interpretation.

Mit der Option "Layer "Endverbraucher" erstellen" kann man diesen in jeder Phase mit erstellen. Der Layer Endverbraucher wird dann, wenn er gemäß GIS-Nb benötigt wird jedoch unabhängig von dieser Option erstellt.

Setzen Sie den Haken bei "Zuweisung neuer IDs", werden die Export-IDs beim Export alle neu gesetzt. Dies ist nach Phase zwei nicht mehr ratsam, da die IDs sich eigentlich von der Bewilligung bis zum Verwendungsnachweis nicht mehr ändern sollen.

Sind die Optionen, wie gewünscht gesetzt, nutzen Sie den "Weiter" Knopf um auf Seite drei des Assistenten zu gelangen.

eng_export_wizard_p3_options.png

Hier können Sie Attribute festlegen, die zusätzlich zu den geforderten Attributen nach GIS-Nb mit exportieren möchten. Nach Rücksprache mit den Projektträgern ist es auch kein Problem zusätzliche Informationen mit abzugeben, die zusätzlichen Layer sind aber besonders zur Kontrolle und bei Rückfragen nützlich um die exportierten Objekte leichter zu identifizieren.

Wenn Sie festgelegt haben, ob und welche zusätzlichen Attribute Sie exportieren möchten, dann nutzen Sie den Button "Weiter" um die letzten Einstellungen für den Export zu treffen.

eng_export_wizard_p4_options.png

Damit Sie den Export starten können, müssen Sie ein Verzeichnis angeben, in welchem die Dateien gesichert werden. Unabhängig davon, ob Sie als Exportformat Shape, GeoJSON oder beides wählen, entstehen immer mehrere Dateien. Diese haben als Dateinamen den Namen des Layers in den GIS-Nb und die passende Dateiendung. Beachten Sie dies bei der Auswahl des Zielverzeichnisses.

Des Weiteren können Sie entscheiden, ob die Liste mit Warnungen und Fehlern, die nach dem Export angezeigt wird, auch automatisch mit in diesem Verzeichnis abgelegt werden soll.

Starten Sie den Export dann, indem Sie auf den Knopf "Fertig stellen" klicken.